Το παιχνιδι σας..!

Ο τομέας μας. ;)
Memas
Δημοσιεύσεις: 87
Εγγραφή: Παρ Δεκ 31, 2010 4:13 pm
Επικοινωνία:

Re: Το παιχνιδι σας..!

Δημοσίευση από Memas » Δευ Ιαν 10, 2011 6:16 pm

Ευχαριστώ,πάντως δεν είχα ιδέα για το megaupload απλά τώρα εν ώρα ανάγκης γράφτηκα...Δεν το χρησιμοποιώ ... Λοιπόν για να μην τρελαθείται...χαχαχαχαχα καθώς είναι το 2 μεγαλύτερο πρόγραμμα που έχω κάνει θα σας δώσω τον κώδικα για τον 1 χρήστη..Του 2 είναι ο ίδιος με μερικές αλλαγές...π.χ όπου 1 βάζεται 2 και αντιστρέφεται την επίθεση με την άμυνα...απλά. ;) Τώρα το προγραμματάκι παίρνει πολλές βελτιώσεις που πραγματικά βαριόμουν να κάνω...Προειδοποίηση:Αν αντιγράψετε τις τεχνικές μου μάλλον θα ξεχάσετε και αυτά που ξέρετε...χαχαχχαχ :lol:

Κώδικας: Επιλογή όλων

ΠΡΟΓΡΑΜΜΑ Battleships
ΑΡΧΗ
  κάλεσε παιχνίδι
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ταμπλό
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αχ,αψ,β,γ,θ_ψ[10],ψ,χ,επα
  ΧΑΡΑΚΤΗΡΕΣ:θ_χ[10]
ΑΡΧΗ
  θ_χ[1] <-- 'A'
  θ_χ[2] <-- 'B'
  θ_χ[3] <-- 'C'
  θ_χ[4] <-- 'D'
  θ_χ[5] <-- 'E'
  θ_χ[6] <-- 'F'
  θ_χ[7] <-- 'G'
  θ_χ[8] <-- 'H'
  θ_χ[9] <-- 'I'
  θ_χ[10] <-- 'J'

  επα <-- 0
  β <-- 2
  χ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ αχ από 1 μέχρι 11
      ΓΙΑ αψ από 2 μέχρι 21
        ΑΝ αχ=1 τοτε
          αν αψ MOD 2=0 τότε
            ΠΗΓΑΙΝΕ_ΧΥ β-2,αψ
            ΓΡΑΨΕ  θ_χ[χ]
            ΠΗΓΑΙΝΕ_ΧΥ β,αψ
            ΓΡΑΨΕ '|'
            χ <-- χ+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΠΗΓΑΙΝΕ_ΧΥ β,αψ
          ΓΡΑΨΕ '|'
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43
    χ <-- 1
    επα <-- επα+1
  ΜΕΧΡΙΣ_ΟΤΟΥ επα=2

  ψ <-- 1
  β <-- 2
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ '',ψ
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 2
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ψ <-- 1
  β <-- 43
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ '',ψ
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ παιχνίδι

ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: κ_π1,απα,κ_π2,υπολ
  ΑΚΕΡΑΙΕΣ: χ,επιλ_χ[100],επιλ_ψ[100],θεσ_πλ_χ_π[17],θεσ_πλ_ψ_π[17],θεσ_πλ_χ_π2[17],θεσ_πλ_ψ_π2[17]
  ΑΚΕΡΑΙΕΣ:θ_χ,θ_ψ,απαντ,κ,λ,επιλχ,επιλψ,θεση,προ[300],δ,μεγεθ,ψ
  ΛΟΓΙΚΕΣ: προτο,αλλαγη,υπαρχ,στοχος
  ΧΑΡΑΚΤΗΡΕΣ:ονομ1,ονομ2,κατ,εγγ,θε1,θε2

  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: π1,π2
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: Θεση_κ,θ1,θ2

ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Θεση_κ ,'C:\POSITION.dll'
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\POSITION.dll')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Θεση_κ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ
  ΤΕΛΟΣ_ΑΝ


  ΠΗΓΑΙΝΕ_ΧΥ 0,8
  ΓΡΑΨΕ '|'
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 79,8
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,9
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 18,3
  ΓΡΑΨΕ 'Καλωσήρθατε στο BattleShips v2.(lan).'
  ΠΗΓΑΙΝΕ_ΧΥ 0,6
  ΓΡΑΨΕ 'Ακολουθήστε τα παρακάτω βήματα.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,7
  ΓΡΑΨΕ '==============================================================================='
  ΠΗΓΑΙΝΕ_ΧΥ 3,8
  ΓΡΑΨΕ_ '1.Δώσε το όνομά σου (μικρότερο από 7 γράμματα):'
  ΠΗΓΑΙΝΕ_ΧΥ 3,9
  ΓΡΑΨΕ_ '3.Πάτα [3] αν είσαι έτοιμος για την αρχή του παιχνιδιού ή [4] για έξοδο.( )'
  ΠΗΓΑΙΝΕ_ΧΥ 0,10
  ΓΡΑΨΕ '==============================================================================='


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 51,8
    ΓΡΑΨΕ '                           '
    ΠΗΓΑΙΝΕ_ΧΥ 51,8
    ΔΙΑΒΑΣΕ  ονομ1
  ΜΕΧΡΙΣ_ΟΤΟΥ ονομ1[ ΜΗΚΟΣ_ΧΑΡ(ονομ1)] <>' ' και ΜΗΚΟΣ_ΧΑΡ(ονομ1)<7


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 76,9
    ΓΡΑΨΕ ''
    ΠΗΓΑΙΝΕ_ΧΥ 76,9
    ΔΙΑΒΑΣΕ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=3 ή απα =4

  ΑΝ απα=4 τοτε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 35,12
    γράψε'Αντίο....'
    ΓΙΑ χ από 1 μέχρι 19999999
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
  ΤΕΛΟΣ_ΑΝ


  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΠΗΓΑΙΝΕ_ΧΥ 25,5
  ΓΡΑΨΕ 'Πληροφορίες'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '==============================================================================='
  ΓΡΑΨΕ '              Δώστε τη δικία σας διεύθυνση που βλέπει ο αντίπαλος:'
  ΔΙΑΒΑΣΕ θε1
  ΓΡΑΨΕ '              Δώστε τη  διεύθυνση του αντίπαλού σας:'
  ΔΙΑΒΑΣΕ θε2



  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ π1 ,θε1+'\P1.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ π1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ π1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(π1)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ π1,ονομ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π1

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ θ1 ,θε1+'\81.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ θ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1


  υπαρχ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ θ2 ,θε2+'\82.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ π2 ,θε2+'\P2.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
    ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ(θε2+'\P2.dll')= ΑΛΗΘΗΣ και ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ(θε2+'\82.dll')= ΑΛΗΘΗΣ ΤΟΤΕ
      υπαρχ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ
      κατ <-- 'Περιμένετε μέχρις ότου να συνδεθεί και ο άλλος παίκτης...'
      ΚΑΛΕΣΕ μπαρα(κατ)
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ υπαρχ= ΑΛΗΘΗΣ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΚΑΛΕΣΕ ταμπλό

  κ_π1 <-- 0
  χ <-- 1
  ψ <-- 1
  δ <-- 1
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ επανάλαβε
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
    αν δ=1 τοτε
      ονομ2 <-- εγγ
    ΤΕΛΟΣ_ΑΝ
    δ <-- δ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θεση_κ                       !Ανοιγμα έτοιμων θέσεων
  αν ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)>0 τότε
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ_ 'Φαίνεται ότι υπάρχουν διαθέσιμες θέσεις για τα καράβια.Για να τα φορτώσεις πάτα [1] αλλιώς αλλο για συνέχεια:'
    ΔΙΑΒΑΣΕ_ απαντ
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                                                       '
  ΤΕΛΟΣ_ΑΝ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ  θεση_κ


  ΟΣΟ κ_π1<17 επανάλαβε

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΠΗΓΑΙΝΕ_ΧΥ 34,2
      ΓΡΑΨΕ ονομ1
      ΠΗΓΑΙΝΕ_ΧΥ 34,3
      ΓΡΑΨΕ κ_π1,'χ @'


      ΠΗΓΑΙΝΕ_ΧΥ 74,2
      ΓΡΑΨΕ ονομ2

      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
      ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2
      ΠΗΓΑΙΝΕ_ΧΥ 74,3

      αν εγγ=ονομ2 τοτε
        ΓΡΑΨΕ 'Θέσεις'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ εγγ
      ΤΕΛΟΣ_ΑΝ



      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ1
      αν απαντ=1 τότε  ! !Στησιμο καραβιών παίχτη από τις έτοιμες θέσεις

        ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Θεση_κ
        χ <-- 1
        ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_χ
          θεσ_πλ_χ_π[χ] <-- θ_χ

          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
          ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θ_χ

          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_ψ
          θεσ_πλ_ψ_π[χ] <-- θ_ψ

          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
          ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θ_ψ

          ΠΗΓΑΙΝΕ_ΧΥ  θεσ_πλ_χ_π[χ], θεσ_πλ_ψ_π[χ]
          ΓΡΑΨΕ '@'
          χ <-- χ+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        κ_π1 <-- 17
        ΠΗΓΑΙΝΕ_ΧΥ 34,3
        ΓΡΑΨΕ κ_π1,'χ @'
        απα <-- 1
        ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ

      ΑΛΛΙΩΣ                !Στησιμο καραβιών παίχτη
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                        '
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ_ 'Δώσε συντεταγμένες για το στήσιμο των καραβιών σου (χ,ψ):(  ,  )'
          ΠΗΓΑΙΝΕ_ΧΥ 59,23
          ΔΙΑΒΑΣΕ_ επιλ_χ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ 62,23
          ΔΙΑΒΑΣΕ_ επιλ_ψ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ 42,23
          ΓΡΑΨΕ '                    '
        ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[χ]>0 και επιλ_χ[χ]<11 και επιλ_ψ[χ]>0 και επιλ_ψ[χ]<11
        προτο <-- ΨΕΥΔΗΣ
        αλλαγη <-- ΨΕΥΔΗΣ
        αν χ>1 τότε                      !έλενγχος γνησιότητας των θέσεων
          ψ <-- 1
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            αν  επιλ_χ[χ]<>επιλ_χ[χ-ψ] ή επιλ_ψ[χ]<>επιλ_ψ[χ-ψ] τότε
              προτο <-- ΑΛΗΘΗΣ
            ΑΛΛΙΩΣ
              αλλαγη <-- ΑΛΗΘΗΣ
            ΤΕΛΟΣ_ΑΝ
            ψ <-- ψ+1
          μέχρις_ότου ψ=χ
        ΤΕΛΟΣ_ΑΝ

        αν προτο=ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή χ=1 τοτε

          θεσ_πλ_χ_π[χ] <-- επιλ_χ[χ]*3
          θεσ_πλ_ψ_π[χ] <-- επιλ_ψ[χ]*2


          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                         '
          ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
          ΓΡΑΨΕ '@'
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ_ 'Είστε ικανοποιημένος με αυτήν σου τη θέση? Αν όχι πάτα 11 αλλιώς αλλο.'         !Επαλήθευση θέσης
          ΔΙΑΒΑΣΕ απα
          αν απα=11 τότε
            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                         '
            ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ ' '
          ΑΛΛΙΩΣ
            ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ '@'

            ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
            ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1, θεσ_πλ_χ_π[χ]

            ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
            ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεσ_πλ_ψ_π[χ]

            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                         '
            κ_π1 <-- κ_π1+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          αν χ>1 τότε
            απα <-- 11
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ απα<>11
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π1
  κατ <-- 'Ready'
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ π1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(π1)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ π1,κατ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π1

  κατ <-- κατ+'.Αναμαίνετε να συνδεθεί ο\η αλλος παίκτης...'

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                         '
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ κατ
    ΓΙΑ δ από 1 μέχρι 10
      ΠΗΓΑΙΝΕ_ΧΥ 52+δ ,23
      ΓΡΑΨΕ_ ΧΑΡ(396)
      ΓΙΑ ψ από 1 μέχρι 10000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
    ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2

  ΜΕΧΡΙΣ_ΟΤΟΥ εγγ='Ready'
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!  αναγνωση θέσεων π2
  χ <-- 1
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ2
  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(θ2)= ΨΕΥΔΗΣ επανάλαβε
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,θ_χ
    θεσ_πλ_χ_π2[χ] <-- θ_χ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,θ_ψ
    θεσ_πλ_ψ_π2[χ] <-- θ_ψ
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  μεγεθ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ2
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1

  υπολ <-- 100

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ2
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ1
  κ_π2 <-- 17
  κ <-- 1
  λ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΠΗΓΑΙΝΕ_ΧΥ 74,2
    ΓΡΑΨΕ ονομ2                                !επίθεση παίκτη
    ΠΗΓΑΙΝΕ_ΧΥ 74,3
    ΓΡΑΨΕ κ_π2,'χ @'
    στοχος <-- ΨΕΥΔΗΣ                                                                                                 

    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                    '
    ΠΗΓΑΙΝΕ_ΧΥ 34,2
    ΓΡΑΨΕ  ονομ1
    ΠΗΓΑΙΝΕ_ΧΥ 34,3
    ΓΡΑΨΕ κ_π1,'χ @'
    ΠΗΓΑΙΝΕ_ΧΥ 34,4
    ΓΡΑΨΕ υπολ

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                              '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ_ 'Δώσε (χ,ψ) κτυπήματος για την επίθεσή σου:(  ,  )'
        ΠΗΓΑΙΝΕ_ΧΥ 44,23
        ΔΙΑΒΑΣΕ_ επιλ_χ[κ]
        ΠΗΓΑΙΝΕ_ΧΥ 47,23
        ΔΙΑΒΑΣΕ_ επιλ_ψ[κ]
      ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[κ]<11 και επιλ_χ[κ]>0 και επιλ_ψ[κ]<11 και επιλ_ψ[κ]>0

      προτο <-- ΨΕΥΔΗΣ
      αλλαγη <-- ΨΕΥΔΗΣ

      αν κ>1 τότε
        ψ <-- 1
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          αν  επιλ_χ[κ]<>επιλ_χ[κ-ψ] ή επιλ_ψ[κ]<>επιλ_ψ[κ-ψ] τότε
            προτο <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
            αλλαγη <-- ΑΛΗΘΗΣ
          ΤΕΛΟΣ_ΑΝ
          ψ <-- ψ+1
        μέχρις_ότου ψ=κ
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ προτο= ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή κ=1

    επιλχ <-- επιλ_χ[κ]*3
    επιλψ <-- επιλ_ψ[κ]*2
    στοχος <-- ΨΕΥΔΗΣ
    κ <-- κ+1
    χ <-- 1
    ΟΣΟ χ<18 επαναλαβε
      αν επιλχ=θεσ_πλ_χ_π2[χ] και επιλψ=θεσ_πλ_ψ_π2[χ] τότε
        στοχος <-- ΑΛΗΘΗΣ
        θεση <-- χ

      ΤΕΛΟΣ_ΑΝ
      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ στοχος=ΑΛΗΘΗΣ τοτε

      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεση

      κάλεσε ήχο
      ΠΗΓΑΙΝΕ_ΧΥ επιλχ+41,επιλψ
      ΓΡΑΨΕ '!'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                            '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Εβγε...'

      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      κ_π2 <-- κ_π2-1
    ΑΛΛΙΩΣ

      θεση <-- 0
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,επιλχ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,επιλψ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεση

      ΠΗΓΑΙΝΕ_ΧΥ  επιλχ+41,επιλψ
      ΓΡΑΨΕ '0'

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                            '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Αστόχησες....'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!1!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!11
!Επίθεση υπολογιστή


    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                         '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Η σειρά του\της ',ονομ2,' τώρα...'
      ΓΙΑ δ από 1 μέχρι 10
        ΠΗΓΑΙΝΕ_ΧΥ 52+δ ,23
        ΓΡΑΨΕ_ ΧΑΡ(396)
        ΓΙΑ ψ από 1 μέχρι 10000000
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΕΧΡΙΣ_ΟΤΟΥ  μεγεθ< ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)

    μεγεθ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)

    λ <-- 0
    ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(θ2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      λ <-- λ+1
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,προ[λ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


    αν προ[λ]<>0 τότε
      κάλεσε ήχο
      ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[προ[λ]],θεσ_πλ_ψ_π[προ[λ]]
      ΓΡΑΨΕ '!'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                   '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Κτυπήθηκες'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      κ_π1 <-- κ_π1-1

    ΑΛΛΙΩΣ

      επιλχ <-- προ[λ-2]
      επιλψ <-- προ[λ-1]

      ΠΗΓΑΙΝΕ_ΧΥ  επιλχ,επιλψ
      ΓΡΑΨΕ '0'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                    '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Ουφ....'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ

    υπολ <-- υπολ-1

  ΜΕΧΡΙΣ_ΟΤΟΥ κ_π1=0 ή υπολ=0 ή κ_π2=0
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ2


  αν κ_π1>κ_π2  τότε
    κατ <-- 'Συνγχαρητήρια, νίκησες !'
  ΑΛΛΙΩΣ_ΑΝ κ_π1=κ_π2  τότε
    κατ <-- '   Ισοπαλία...'
  ΑΛΛΙΩΣ
    κατ <-- 'Δυστυχώς ,έχασες...'
  ΤΕΛΟΣ_ΑΝ
  απα <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 20,8
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 20,9
    ΓΡΑΨΕ '|   /\         The Game is over!          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,10
    ΓΡΑΨΕ '|  /! \   ',κατ
    ΠΗΓΑΙΝΕ_ΧΥ 20,11
    ΓΡΑΨΕ '| ------  Για συνέχεια πάτα [1].          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,12
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 62,10
    ΓΡΑΨΕ '|'
    ΠΗΓΑΙΝΕ_ΧΥ 53,11
    ΔΙΑΒΑΣΕ_ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=1
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ θ1
  ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ π1

  ΚΑΛΕΣΕ παιχνίδι
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ καθ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 10000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ήχο
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 5
    ΓΡΑΨΕ_ χαρ(7)
    κάλεσε καθ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!11
ΔΙΑΔΙΚΑΣΙΑ μπαρα(κατασταση)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: κατασταση
  ΑΚΕΡΑΙΕΣ: α,β
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΠΗΓΑΙΝΕ_ΧΥ 15,3
  ΓΡΑΨΕ κατασταση
  ΓΙΑ β από 1 μέχρι 20
    ΠΗΓΑΙΝΕ_ΧΥ 25+β,6
    ΓΡΑΨΕ_ ΧΑΡ(396)
    ΓΙΑ α από 1 μέχρι 1000000
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Τελευταία επεξεργασία από το μέλος thetrojan01 την Δευ Ιαν 10, 2011 6:31 pm, έχει επεξεργασθεί 2 φορές συνολικά.
Λόγος: codes go inside [code] tags. & Τα quotes είναι ΜΟΝΟ για παράθεση λόγου.

Virus•Hacker•Kontos
Δημοσιεύσεις: 170
Εγγραφή: Πέμ Νοέμ 26, 2009 9:59 pm

Re: Το παιχνιδι σας..!

Δημοσίευση από Virus•Hacker•Kontos » Δευ Ιαν 10, 2011 11:40 pm

Memas έγραψε:Ευχαριστώ,πάντως δεν είχα ιδέα για το megaupload απλά τώρα εν ώρα ανάγκης γράφτηκα...Δεν το χρησιμοποιώ ... Λοιπόν για να μην τρελαθείται...χαχαχαχαχα καθώς είναι το 2 μεγαλύτερο πρόγραμμα που έχω κάνει θα σας δώσω τον κώδικα για τον 1 χρήστη..Του 2 είναι ο ίδιος με μερικές αλλαγές...π.χ όπου 1 βάζεται 2 και αντιστρέφεται την επίθεση με την άμυνα...απλά. ;) Τώρα το προγραμματάκι παίρνει πολλές βελτιώσεις που πραγματικά βαριόμουν να κάνω...Προειδοποίηση:Αν αντιγράψετε τις τεχνικές μου μάλλον θα ξεχάσετε και αυτά που ξέρετε...χαχαχχαχ :lol:
Spoiler: show

Κώδικας: Επιλογή όλων

ΠΡΟΓΡΑΜΜΑ Battleships
ΑΡΧΗ
  κάλεσε παιχνίδι
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ταμπλό
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: αχ,αψ,β,γ,θ_ψ[10],ψ,χ,επα
  ΧΑΡΑΚΤΗΡΕΣ:θ_χ[10]
ΑΡΧΗ
  θ_χ[1] <-- 'A'
  θ_χ[2] <-- 'B'
  θ_χ[3] <-- 'C'
  θ_χ[4] <-- 'D'
  θ_χ[5] <-- 'E'
  θ_χ[6] <-- 'F'
  θ_χ[7] <-- 'G'
  θ_χ[8] <-- 'H'
  θ_χ[9] <-- 'I'
  θ_χ[10] <-- 'J'

  επα <-- 0
  β <-- 2
  χ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ αχ από 1 μέχρι 11
      ΓΙΑ αψ από 2 μέχρι 21
        ΑΝ αχ=1 τοτε
          αν αψ MOD 2=0 τότε
            ΠΗΓΑΙΝΕ_ΧΥ β-2,αψ
            ΓΡΑΨΕ  θ_χ[χ]
            ΠΗΓΑΙΝΕ_ΧΥ β,αψ
            ΓΡΑΨΕ '|'
            χ <-- χ+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΠΗΓΑΙΝΕ_ΧΥ β,αψ
          ΓΡΑΨΕ '|'
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43
    χ <-- 1
    επα <-- επα+1
  ΜΕΧΡΙΣ_ΟΤΟΥ επα=2

  ψ <-- 1
  β <-- 2
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ '',ψ
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 2
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ψ <-- 1
  β <-- 43
  γ <-- 1
  για αχ από 1 μέχρι 11
    ΓΙΑ αψ από 1 μέχρι 10
      αν αχ=11 τοτε
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
        ΠΗΓΑΙΝΕ_ΧΥ β,γ+1
        ΓΡΑΨΕ '',ψ
        ψ <-- ψ+1
      ΑΛΛΙΩΣ
        ΠΗΓΑΙΝΕ_ΧΥ β,γ
        ΓΡΑΨΕ ' --'
      ΤΕΛΟΣ_ΑΝ
      β <-- β+3
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    β <-- 43
    γ <-- γ+2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ΔΙΑΔΙΚΑΣΙΑ παιχνίδι

ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: κ_π1,απα,κ_π2,υπολ
  ΑΚΕΡΑΙΕΣ: χ,επιλ_χ[100],επιλ_ψ[100],θεσ_πλ_χ_π[17],θεσ_πλ_ψ_π[17],θεσ_πλ_χ_π2[17],θεσ_πλ_ψ_π2[17]
  ΑΚΕΡΑΙΕΣ:θ_χ,θ_ψ,απαντ,κ,λ,επιλχ,επιλψ,θεση,προ[300],δ,μεγεθ,ψ
  ΛΟΓΙΚΕΣ: προτο,αλλαγη,υπαρχ,στοχος
  ΧΑΡΑΚΤΗΡΕΣ:ονομ1,ονομ2,κατ,εγγ,θε1,θε2

  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: π1,π2
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: Θεση_κ,θ1,θ2

ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Θεση_κ ,'C:\POSITION.dll'
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\POSITION.dll')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Θεση_κ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ
  ΤΕΛΟΣ_ΑΝ


  ΠΗΓΑΙΝΕ_ΧΥ 0,8
  ΓΡΑΨΕ '|'
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 79,8
  ΓΡΑΨΕ '|'
  ΠΗΓΑΙΝΕ_ΧΥ 79,9
  ΓΡΑΨΕ '|'

  ΠΗΓΑΙΝΕ_ΧΥ 18,3
  ΓΡΑΨΕ 'Καλωσήρθατε στο BattleShips v2.(lan).'
  ΠΗΓΑΙΝΕ_ΧΥ 0,6
  ΓΡΑΨΕ 'Ακολουθήστε τα παρακάτω βήματα.'
  ΠΗΓΑΙΝΕ_ΧΥ 0,7
  ΓΡΑΨΕ '==============================================================================='
  ΠΗΓΑΙΝΕ_ΧΥ 3,8
  ΓΡΑΨΕ_ '1.Δώσε το όνομά σου (μικρότερο από 7 γράμματα):'
  ΠΗΓΑΙΝΕ_ΧΥ 3,9
  ΓΡΑΨΕ_ '3.Πάτα [3] αν είσαι έτοιμος για την αρχή του παιχνιδιού ή [4] για έξοδο.( )'
  ΠΗΓΑΙΝΕ_ΧΥ 0,10
  ΓΡΑΨΕ '==============================================================================='


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 51,8
    ΓΡΑΨΕ '                           '
    ΠΗΓΑΙΝΕ_ΧΥ 51,8
    ΔΙΑΒΑΣΕ  ονομ1
  ΜΕΧΡΙΣ_ΟΤΟΥ ονομ1[ ΜΗΚΟΣ_ΧΑΡ(ονομ1)] <>' ' και ΜΗΚΟΣ_ΧΑΡ(ονομ1)<7


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 76,9
    ΓΡΑΨΕ ''
    ΠΗΓΑΙΝΕ_ΧΥ 76,9
    ΔΙΑΒΑΣΕ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=3 ή απα =4

  ΑΝ απα=4 τοτε
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 35,12
    γράψε'Αντίο....'
    ΓΙΑ χ από 1 μέχρι 19999999
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
  ΤΕΛΟΣ_ΑΝ


  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΠΗΓΑΙΝΕ_ΧΥ 25,5
  ΓΡΑΨΕ 'Πληροφορίες'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '==============================================================================='
  ΓΡΑΨΕ '              Δώστε τη δικία σας διεύθυνση που βλέπει ο αντίπαλος:'
  ΔΙΑΒΑΣΕ θε1
  ΓΡΑΨΕ '              Δώστε τη  διεύθυνση του αντίπαλού σας:'
  ΔΙΑΒΑΣΕ θε2



  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ π1 ,θε1+'\P1.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ π1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ π1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(π1)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ π1,ονομ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π1

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ θ1 ,θε1+'\81.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ θ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1


  υπαρχ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ θ2 ,θε2+'\82.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ π2 ,θε2+'\P2.dll'    !Διορθώστε την θέση του κοινόχροιστου αν είναι λάθος
    ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ(θε2+'\P2.dll')= ΑΛΗΘΗΣ και ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ(θε2+'\82.dll')= ΑΛΗΘΗΣ ΤΟΤΕ
      υπαρχ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ
      κατ <-- 'Περιμένετε μέχρις ότου να συνδεθεί και ο άλλος παίκτης...'
      ΚΑΛΕΣΕ μπαρα(κατ)
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ υπαρχ= ΑΛΗΘΗΣ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΚΑΛΕΣΕ ταμπλό

  κ_π1 <-- 0
  χ <-- 1
  ψ <-- 1
  δ <-- 1
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ επανάλαβε
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
    αν δ=1 τοτε
      ονομ2 <-- εγγ
    ΤΕΛΟΣ_ΑΝ
    δ <-- δ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θεση_κ                       !Ανοιγμα έτοιμων θέσεων
  αν ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)>0 τότε
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ_ 'Φαίνεται ότι υπάρχουν διαθέσιμες θέσεις για τα καράβια.Για να τα φορτώσεις πάτα [1] αλλιώς αλλο για συνέχεια:'
    ΔΙΑΒΑΣΕ_ απαντ
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                                                       '
  ΤΕΛΟΣ_ΑΝ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ  θεση_κ


  ΟΣΟ κ_π1<17 επανάλαβε

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΠΗΓΑΙΝΕ_ΧΥ 34,2
      ΓΡΑΨΕ ονομ1
      ΠΗΓΑΙΝΕ_ΧΥ 34,3
      ΓΡΑΨΕ κ_π1,'χ @'


      ΠΗΓΑΙΝΕ_ΧΥ 74,2
      ΓΡΑΨΕ ονομ2

      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
      ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2
      ΠΗΓΑΙΝΕ_ΧΥ 74,3

      αν εγγ=ονομ2 τοτε
        ΓΡΑΨΕ 'Θέσεις'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ εγγ
      ΤΕΛΟΣ_ΑΝ



      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ1
      αν απαντ=1 τότε  ! !Στησιμο καραβιών παίχτη από τις έτοιμες θέσεις

        ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Θεση_κ
        χ <-- 1
        ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(Θεση_κ)=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_χ
          θεσ_πλ_χ_π[χ] <-- θ_χ

          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
          ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θ_χ

          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Θεση_κ, θ_ψ
          θεσ_πλ_ψ_π[χ] <-- θ_ψ

          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
          ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θ_ψ

          ΠΗΓΑΙΝΕ_ΧΥ  θεσ_πλ_χ_π[χ], θεσ_πλ_ψ_π[χ]
          ΓΡΑΨΕ '@'
          χ <-- χ+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        κ_π1 <-- 17
        ΠΗΓΑΙΝΕ_ΧΥ 34,3
        ΓΡΑΨΕ κ_π1,'χ @'
        απα <-- 1
        ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Θεση_κ

      ΑΛΛΙΩΣ                !Στησιμο καραβιών παίχτη
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                        '
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ_ 'Δώσε συντεταγμένες για το στήσιμο των καραβιών σου (χ,ψ):(  ,  )'
          ΠΗΓΑΙΝΕ_ΧΥ 59,23
          ΔΙΑΒΑΣΕ_ επιλ_χ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ 62,23
          ΔΙΑΒΑΣΕ_ επιλ_ψ[χ]
          ΠΗΓΑΙΝΕ_ΧΥ 42,23
          ΓΡΑΨΕ '                    '
        ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[χ]>0 και επιλ_χ[χ]<11 και επιλ_ψ[χ]>0 και επιλ_ψ[χ]<11
        προτο <-- ΨΕΥΔΗΣ
        αλλαγη <-- ΨΕΥΔΗΣ
        αν χ>1 τότε                      !έλενγχος γνησιότητας των θέσεων
          ψ <-- 1
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            αν  επιλ_χ[χ]<>επιλ_χ[χ-ψ] ή επιλ_ψ[χ]<>επιλ_ψ[χ-ψ] τότε
              προτο <-- ΑΛΗΘΗΣ
            ΑΛΛΙΩΣ
              αλλαγη <-- ΑΛΗΘΗΣ
            ΤΕΛΟΣ_ΑΝ
            ψ <-- ψ+1
          μέχρις_ότου ψ=χ
        ΤΕΛΟΣ_ΑΝ

        αν προτο=ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή χ=1 τοτε

          θεσ_πλ_χ_π[χ] <-- επιλ_χ[χ]*3
          θεσ_πλ_ψ_π[χ] <-- επιλ_ψ[χ]*2


          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ '                                                                                         '
          ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
          ΓΡΑΨΕ '@'
          ΠΗΓΑΙΝΕ_ΧΥ 0,23
          ΓΡΑΨΕ_ 'Είστε ικανοποιημένος με αυτήν σου τη θέση? Αν όχι πάτα 11 αλλιώς αλλο.'         !Επαλήθευση θέσης
          ΔΙΑΒΑΣΕ απα
          αν απα=11 τότε
            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                         '
            ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ ' '
          ΑΛΛΙΩΣ
            ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[χ],θεσ_πλ_ψ_π[χ]
            ΓΡΑΨΕ '@'

            ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
            ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1, θεσ_πλ_χ_π[χ]

            ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
            ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεσ_πλ_ψ_π[χ]

            ΠΗΓΑΙΝΕ_ΧΥ 0,23
            ΓΡΑΨΕ '                                                                                         '
            κ_π1 <-- κ_π1+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          αν χ>1 τότε
            απα <-- 11
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ απα<>11
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π1
  κατ <-- 'Ready'
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ π1, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(π1)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ π1,κατ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π1

  κατ <-- κατ+'.Αναμαίνετε να συνδεθεί ο\η αλλος παίκτης...'

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                         '
    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ κατ
    ΓΙΑ δ από 1 μέχρι 10
      ΠΗΓΑΙΝΕ_ΧΥ 52+δ ,23
      ΓΡΑΨΕ_ ΧΑΡ(396)
      ΓΙΑ ψ από 1 μέχρι 10000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ π2
    ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(π2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ π2,εγγ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ π2

  ΜΕΧΡΙΣ_ΟΤΟΥ εγγ='Ready'
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!  αναγνωση θέσεων π2
  χ <-- 1
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ2
  ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(θ2)= ΨΕΥΔΗΣ επανάλαβε
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,θ_χ
    θεσ_πλ_χ_π2[χ] <-- θ_χ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,θ_ψ
    θεσ_πλ_ψ_π2[χ] <-- θ_ψ
    χ <-- χ+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  μεγεθ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ2
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1

  υπολ <-- 100

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ2
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ θ1
  κ_π2 <-- 17
  κ <-- 1
  λ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΠΗΓΑΙΝΕ_ΧΥ 74,2
    ΓΡΑΨΕ ονομ2                                !επίθεση παίκτη
    ΠΗΓΑΙΝΕ_ΧΥ 74,3
    ΓΡΑΨΕ κ_π2,'χ @'
    στοχος <-- ΨΕΥΔΗΣ                                                                                                 

    ΠΗΓΑΙΝΕ_ΧΥ 0,23
    ΓΡΑΨΕ '                                                                                    '
    ΠΗΓΑΙΝΕ_ΧΥ 34,2
    ΓΡΑΨΕ  ονομ1
    ΠΗΓΑΙΝΕ_ΧΥ 34,3
    ΓΡΑΨΕ κ_π1,'χ @'
    ΠΗΓΑΙΝΕ_ΧΥ 34,4
    ΓΡΑΨΕ υπολ

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ '                                                                                              '
        ΠΗΓΑΙΝΕ_ΧΥ 0,23
        ΓΡΑΨΕ_ 'Δώσε (χ,ψ) κτυπήματος για την επίθεσή σου:(  ,  )'
        ΠΗΓΑΙΝΕ_ΧΥ 44,23
        ΔΙΑΒΑΣΕ_ επιλ_χ[κ]
        ΠΗΓΑΙΝΕ_ΧΥ 47,23
        ΔΙΑΒΑΣΕ_ επιλ_ψ[κ]
      ΜΕΧΡΙΣ_ΟΤΟΥ επιλ_χ[κ]<11 και επιλ_χ[κ]>0 και επιλ_ψ[κ]<11 και επιλ_ψ[κ]>0

      προτο <-- ΨΕΥΔΗΣ
      αλλαγη <-- ΨΕΥΔΗΣ

      αν κ>1 τότε
        ψ <-- 1
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          αν  επιλ_χ[κ]<>επιλ_χ[κ-ψ] ή επιλ_ψ[κ]<>επιλ_ψ[κ-ψ] τότε
            προτο <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
            αλλαγη <-- ΑΛΗΘΗΣ
          ΤΕΛΟΣ_ΑΝ
          ψ <-- ψ+1
        μέχρις_ότου ψ=κ
      ΤΕΛΟΣ_ΑΝ

    ΜΕΧΡΙΣ_ΟΤΟΥ προτο= ΑΛΗΘΗΣ και αλλαγη= ΨΕΥΔΗΣ ή κ=1

    επιλχ <-- επιλ_χ[κ]*3
    επιλψ <-- επιλ_ψ[κ]*2
    στοχος <-- ΨΕΥΔΗΣ
    κ <-- κ+1
    χ <-- 1
    ΟΣΟ χ<18 επαναλαβε
      αν επιλχ=θεσ_πλ_χ_π2[χ] και επιλψ=θεσ_πλ_ψ_π2[χ] τότε
        στοχος <-- ΑΛΗΘΗΣ
        θεση <-- χ

      ΤΕΛΟΣ_ΑΝ
      χ <-- χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ στοχος=ΑΛΗΘΗΣ τοτε

      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεση

      κάλεσε ήχο
      ΠΗΓΑΙΝΕ_ΧΥ επιλχ+41,επιλψ
      ΓΡΑΨΕ '!'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                            '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Εβγε...'

      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      κ_π2 <-- κ_π2-1
    ΑΛΛΙΩΣ

      θεση <-- 0
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,επιλχ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,επιλψ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ θ1,  ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ1)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ θ1,θεση

      ΠΗΓΑΙΝΕ_ΧΥ  επιλχ+41,επιλψ
      ΓΡΑΨΕ '0'

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                            '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Αστόχησες....'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!1!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!11
!Επίθεση υπολογιστή


    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                         '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Η σειρά του\της ',ονομ2,' τώρα...'
      ΓΙΑ δ από 1 μέχρι 10
        ΠΗΓΑΙΝΕ_ΧΥ 52+δ ,23
        ΓΡΑΨΕ_ ΧΑΡ(396)
        ΓΙΑ ψ από 1 μέχρι 10000000
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΕΧΡΙΣ_ΟΤΟΥ  μεγεθ< ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)

    μεγεθ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(θ2)

    λ <-- 0
    ΟΣΟ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(θ2)= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      λ <-- λ+1
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ θ2,προ[λ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


    αν προ[λ]<>0 τότε
      κάλεσε ήχο
      ΠΗΓΑΙΝΕ_ΧΥ θεσ_πλ_χ_π[προ[λ]],θεσ_πλ_ψ_π[προ[λ]]
      ΓΡΑΨΕ '!'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                   '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Κτυπήθηκες'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      κ_π1 <-- κ_π1-1

    ΑΛΛΙΩΣ

      επιλχ <-- προ[λ-2]
      επιλψ <-- προ[λ-1]

      ΠΗΓΑΙΝΕ_ΧΥ  επιλχ,επιλψ
      ΓΡΑΨΕ '0'
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ '                                                                                                    '
      ΠΗΓΑΙΝΕ_ΧΥ 0,23
      ΓΡΑΨΕ 'Ουφ....'
      ΓΙΑ ψ από 1 μέχρι 4
        ΚΑΛΕΣΕ καθ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ

    υπολ <-- υπολ-1

  ΜΕΧΡΙΣ_ΟΤΟΥ κ_π1=0 ή υπολ=0 ή κ_π2=0
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ1
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ θ2


  αν κ_π1>κ_π2  τότε
    κατ <-- 'Συνγχαρητήρια, νίκησες !'
  ΑΛΛΙΩΣ_ΑΝ κ_π1=κ_π2  τότε
    κατ <-- '   Ισοπαλία...'
  ΑΛΛΙΩΣ
    κατ <-- 'Δυστυχώς ,έχασες...'
  ΤΕΛΟΣ_ΑΝ
  απα <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ 20,8
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 20,9
    ΓΡΑΨΕ '|   /\         The Game is over!          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,10
    ΓΡΑΨΕ '|  /! \   ',κατ
    ΠΗΓΑΙΝΕ_ΧΥ 20,11
    ΓΡΑΨΕ '| ------  Για συνέχεια πάτα [1].          |'
    ΠΗΓΑΙΝΕ_ΧΥ 20,12
    ΓΡΑΨΕ '==========================================='
    ΠΗΓΑΙΝΕ_ΧΥ 62,10
    ΓΡΑΨΕ '|'
    ΠΗΓΑΙΝΕ_ΧΥ 53,11
    ΔΙΑΒΑΣΕ_ απα
  ΜΕΧΡΙΣ_ΟΤΟΥ απα=1
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ θ1
  ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ π1

  ΚΑΛΕΣΕ παιχνίδι
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ καθ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 10000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ήχο
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΓΙΑ α από 1 μέχρι 5
    ΓΡΑΨΕ_ χαρ(7)
    κάλεσε καθ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!11
ΔΙΑΔΙΚΑΣΙΑ μπαρα(κατασταση)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: κατασταση
  ΑΚΕΡΑΙΕΣ: α,β
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΠΗΓΑΙΝΕ_ΧΥ 15,3
  ΓΡΑΨΕ κατασταση
  ΓΙΑ β από 1 μέχρι 20
    ΠΗΓΑΙΝΕ_ΧΥ 25+β,6
    ΓΡΑΨΕ_ ΧΑΡ(396)
    ΓΙΑ α από 1 μέχρι 1000000
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
[/spoiler]
Καλά και κάθησες να προγραμματίσεις όλο αυτό το πράγμα σε γλωσσομάθεια;

Τον ίδιο χρόνο θα μπορουσες να είχες κάνει να το προγραμματίσεις και σε DirectX / OpenGL / Flash / Java...
Μην σου πω πως θα έκανες και λιγότερο χρόνο...
DFS Hole:
Spoiler: show
http://virushackerwhizkid.blogspot.com/ ... ze-it.html
DFS = Deep Freeze System
Είμαι σίγουρος ότι το πιστέψατε.

Memas
Δημοσιεύσεις: 87
Εγγραφή: Παρ Δεκ 31, 2010 4:13 pm
Επικοινωνία:

Re: Το παιχνιδι σας..!

Δημοσίευση από Memas » Τρί Ιαν 11, 2011 10:23 pm

:D Με ρώτρησες αν ξέρω.... :lol: :lol: :lol: :lol: :lol:

sotiris
Δημοσιεύσεις: 422
Εγγραφή: Τρί Φεβ 10, 2009 9:49 pm

Re: Το παιχνιδι σας..!

Δημοσίευση από sotiris » Πέμ Φεβ 03, 2011 5:56 pm

Πρόσφατα βρήκα κάτι .mdx (file format) 3Δ μοντέλα και τώρα θέλω να τα φορτώσω στο Blender έτσι ώστε να τα επεξεργαστώ και να τα κάνω export σε .Md2 (file format) . Το κακό είναι ότι δεν βρίσκω πουθενά importer για .mdx για το Blender :( , υπήρχε ένα αποκαλούμενο War Blender (plugin) αλλά από όσο φαίνεται δεν λειτουργεί πλέον.

ΥΓ
Δεν θέλω converter για να κάνω το .mdx σε κάτι άλλο εκτός από .md2 επειδή έτσι θα χαθούν τα καρέ που έχει μέσα το μοντέλο ..... επίσης δεν νομίζω να υπάρχει τετοιος converter διότι οι κορυφές που συντελούν ένα μοντέλο μπορεί να είναι τόσες πολλές έτσι ώστε να υπερβαίνουν το όριο που ορίζει το .MD2 , γιαυτό και πρέπει να το εισάγω πρώτα στο Blender και να μειώσω τις κορυφές του κάνοντας remove double εάν γίνεται κιόλας. Ενναλακτικά θα μπορούσα να κατεβάσω το 3ds Max , αλλά το βρίσκω πολύ χρονοβόρο διότι
1ον) Πρέπει να φορτώσω το μοντέλο στο 3ds maχ ( με την προυπόθεση κιόλας ο importer να φορτώνει και τα καρέ
2ον) Πρέπει να βρω έναν .md2 exporter για το 3ds max έτσι ώστε να εξάγω το μοντέλο
3ον ) Να φορτώσω το μοντέλο που είναι σε .md2 μέσω του Blender έτσι ώστε να αλλάξω το texture που κρατάει το μοντέλο από .blp σε .bmp (Δεν έχω φτιάξει .blp loader)
4ον) Να εξάγω ξανά το μοντέλο σε .md2 μέσω του Blender

Από την άλλη υπάρχει και το MilkShape 3d που μπορεί να κάνει αυτά που θέλω αλλά δεν ξέρω να το χρησιμοποιώ καθόλου :roll:
Εικόνα

Virus•Hacker•Kontos
Δημοσιεύσεις: 170
Εγγραφή: Πέμ Νοέμ 26, 2009 9:59 pm

Re: Το παιχνιδι σας..!

Δημοσίευση από Virus•Hacker•Kontos » Σάβ Φεβ 05, 2011 12:29 am

sotiris έγραψε:Πρόσφατα βρήκα κάτι .mdx (file format) 3Δ μοντέλα και τώρα θέλω να τα φορτώσω στο Blender έτσι ώστε να τα επεξεργαστώ και να τα κάνω export σε .Md2 (file format) . Το κακό είναι ότι δεν βρίσκω πουθενά importer για .mdx για το Blender :( , υπήρχε ένα αποκαλούμενο War Blender (plugin) αλλά από όσο φαίνεται δεν λειτουργεί πλέον.

ΥΓ
Δεν θέλω converter για να κάνω το .mdx σε κάτι άλλο εκτός από .md2 επειδή έτσι θα χαθούν τα καρέ που έχει μέσα το μοντέλο ..... επίσης δεν νομίζω να υπάρχει τετοιος converter διότι οι κορυφές που συντελούν ένα μοντέλο μπορεί να είναι τόσες πολλές έτσι ώστε να υπερβαίνουν το όριο που ορίζει το .MD2 , γιαυτό και πρέπει να το εισάγω πρώτα στο Blender και να μειώσω τις κορυφές του κάνοντας remove double εάν γίνεται κιόλας. Ενναλακτικά θα μπορούσα να κατεβάσω το 3ds Max , αλλά το βρίσκω πολύ χρονοβόρο διότι
1ον) Πρέπει να φορτώσω το μοντέλο στο 3ds maχ ( με την προυπόθεση κιόλας ο importer να φορτώνει και τα καρέ
2ον) Πρέπει να βρω έναν .md2 exporter για το 3ds max έτσι ώστε να εξάγω το μοντέλο
3ον ) Να φορτώσω το μοντέλο που είναι σε .md2 μέσω του Blender έτσι ώστε να αλλάξω το texture που κρατάει το μοντέλο από .blp σε .bmp (Δεν έχω φτιάξει .blp loader)
4ον) Να εξάγω ξανά το μοντέλο σε .md2 μέσω του Blender

Από την άλλη υπάρχει και το MilkShape 3d που μπορεί να κάνει αυτά που θέλω αλλά δεν ξέρω να το χρησιμοποιώ καθόλου :roll:
Το milkshape το εχω δοκιμασει και ειναι αξιολογο, αν και δεν συγκρινεται και πολυ με το Blender, και επιπλεον θα πρεπει να μαθεις τα κουμπια για το Milkshape που ειναι αρκετα διαφορετικα απο το blender.
What are you up to again?
DFS Hole:
Spoiler: show
http://virushackerwhizkid.blogspot.com/ ... ze-it.html
DFS = Deep Freeze System
Είμαι σίγουρος ότι το πιστέψατε.

sotiris
Δημοσιεύσεις: 422
Εγγραφή: Τρί Φεβ 10, 2009 9:49 pm

Re: Το παιχνιδι σας..!

Δημοσίευση από sotiris » Δευ Φεβ 07, 2011 12:39 am

Virus•Hacker•Kontos έγραψε:
sotiris έγραψε:Πρόσφατα βρήκα κάτι .mdx (file format) 3Δ μοντέλα και τώρα θέλω να τα φορτώσω στο Blender έτσι ώστε να τα επεξεργαστώ και να τα κάνω export σε .Md2 (file format) . Το κακό είναι ότι δεν βρίσκω πουθενά importer για .mdx για το Blender :( , υπήρχε ένα αποκαλούμενο War Blender (plugin) αλλά από όσο φαίνεται δεν λειτουργεί πλέον.

ΥΓ
Δεν θέλω converter για να κάνω το .mdx σε κάτι άλλο εκτός από .md2 επειδή έτσι θα χαθούν τα καρέ που έχει μέσα το μοντέλο ..... επίσης δεν νομίζω να υπάρχει τετοιος converter διότι οι κορυφές που συντελούν ένα μοντέλο μπορεί να είναι τόσες πολλές έτσι ώστε να υπερβαίνουν το όριο που ορίζει το .MD2 , γιαυτό και πρέπει να το εισάγω πρώτα στο Blender και να μειώσω τις κορυφές του κάνοντας remove double εάν γίνεται κιόλας. Ενναλακτικά θα μπορούσα να κατεβάσω το 3ds Max , αλλά το βρίσκω πολύ χρονοβόρο διότι
1ον) Πρέπει να φορτώσω το μοντέλο στο 3ds maχ ( με την προυπόθεση κιόλας ο importer να φορτώνει και τα καρέ
2ον) Πρέπει να βρω έναν .md2 exporter για το 3ds max έτσι ώστε να εξάγω το μοντέλο
3ον ) Να φορτώσω το μοντέλο που είναι σε .md2 μέσω του Blender έτσι ώστε να αλλάξω το texture που κρατάει το μοντέλο από .blp σε .bmp (Δεν έχω φτιάξει .blp loader)
4ον) Να εξάγω ξανά το μοντέλο σε .md2 μέσω του Blender

Από την άλλη υπάρχει και το MilkShape 3d που μπορεί να κάνει αυτά που θέλω αλλά δεν ξέρω να το χρησιμοποιώ καθόλου :roll:
Το milkshape το εχω δοκιμασει και ειναι αξιολογο, αν και δεν συγκρινεται και πολυ με το Blender, και επιπλεον θα πρεπει να μαθεις τα κουμπια για το Milkshape που ειναι αρκετα διαφορετικα απο το blender.
What are you up to again?
Δοκίμασα πολλά πράγματα....έψαξα για importers για mdx για το blender , δεν βρήκα....
έκανα convert σε .mdl , έψαξα για importer δεν βρήκα.... και από όσο φαίνεται από κάποιους viewer το convert πρέπει να είναι προβληματικό. Σε κάποια στιγμή βρήκα έναν MDX -> MD3 converter έκανα το μοντέλο σε MD3 και το έκανα import στο Blender , το κακό ήταν ότι μπορούσα να κάνω export μονάχα ένα animation :( . Τελικά κατέβασα το 3ds max 2001 32 bits , κατέβασα έναν MDX importer και κατάφερα να φορτώσω το μοντέλο με το animation. Το μόνο που μένει τώρα είναι να βρω έναν καλό exporter για να μεταφέρω το μοντέλο στο Blender, σκέφτομαι να το κάνω .X ή DAE ή MD2. To Dae πάντως δεν δουλεύει από όσο φαίνεται.

ΥΓ
Θέλω να χρησιμοποιήσω τα μοντέλα για ταχύτερη ανάπτυξη σε ένα 3d-RPG demo που κάνω.
Εικόνα

Virus•Hacker•Kontos
Δημοσιεύσεις: 170
Εγγραφή: Πέμ Νοέμ 26, 2009 9:59 pm

Re: Το παιχνιδι σας..!

Δημοσίευση από Virus•Hacker•Kontos » Τρί Φεβ 08, 2011 3:38 pm

sotiris έγραψε:
Δοκίμασα πολλά πράγματα....έψαξα για importers για mdx για το blender , δεν βρήκα....
έκανα convert σε .mdl , έψαξα για importer δεν βρήκα.... και από όσο φαίνεται από κάποιους viewer το convert πρέπει να είναι προβληματικό. Σε κάποια στιγμή βρήκα έναν MDX -> MD3 converter έκανα το μοντέλο σε MD3 και το έκανα import στο Blender , το κακό ήταν ότι μπορούσα να κάνω export μονάχα ένα animation :( . Τελικά κατέβασα το 3ds max 2001 32 bits , κατέβασα έναν MDX importer και κατάφερα να φορτώσω το μοντέλο με το animation. Το μόνο που μένει τώρα είναι να βρω έναν καλό exporter για να μεταφέρω το μοντέλο στο Blender, σκέφτομαι να το κάνω .X ή DAE ή MD2. To Dae πάντως δεν δουλεύει από όσο φαίνεται.

ΥΓ
Θέλω να χρησιμοποιήσω τα μοντέλα για ταχύτερη ανάπτυξη σε ένα 3d-RPG demo που κάνω.
????
Να φανταστω ενοεις το 2011...

Στείλε ΠΜ ποτε θα είσαι online στο msn, να μου πεις περισσοτερα για το 3d-RPG demo, γιατι με ενδιαφερει αμεσα καθως ξαναπιασα προσφατα εκεινο το game που σου ελεγα πως θα χρειαζομουν μοντελα...
DFS Hole:
Spoiler: show
http://virushackerwhizkid.blogspot.com/ ... ze-it.html
DFS = Deep Freeze System
Είμαι σίγουρος ότι το πιστέψατε.

Memas
Δημοσιεύσεις: 87
Εγγραφή: Παρ Δεκ 31, 2010 4:13 pm
Επικοινωνία:

Re: Το παιχνιδι σας..!

Δημοσίευση από Memas » Παρ Φεβ 11, 2011 5:17 pm

Καταρχάς χρόνια πολλά στον Virus Hacker Kontos.Θυμάστε το Battleships lan? Τελικά εχθές το δοκίμασα και παίζει μια χαρά βέβαια για να φτιάξετε τις διευθύνσεις θέλει λίγο κόπο , αλλά γλωσσομάθεια είναι αυτή. :D

sotiris
Δημοσιεύσεις: 422
Εγγραφή: Τρί Φεβ 10, 2009 9:49 pm

Re: Το παιχνιδι σας..!

Δημοσίευση από sotiris » Σάβ Ιούλ 16, 2011 11:18 am

Παρακάτω παραθέτω έναν σύνδεσμο βίντεου ενός 3d Kingdom hearts clone που αναπτύζω.

http://www.youtube.com/watch?v=oWHtLphlwHQ

Εικόνα

giorgos.kriti
Δημοσιεύσεις: 6
Εγγραφή: Τρί Φεβ 07, 2012 10:53 pm

Re: Το παιχνιδι σας..!

Δημοσίευση από giorgos.kriti » Τετ Φεβ 08, 2012 1:10 am

errietta έγραψε:Εγώ έχω φτιάξει ένα browser game (με αρκετούς χρήστες!) σε PHP & javascript (μπορείτε να το δείτε στο pokemonlake.com αν θέλετε). Μην παραπονεθείτε για το design, το φτιάχνω τώρα!

poly kalo

Απάντηση